Visualiser

After I drag the replay folder the screen just goes blank and just displays the background.

Using Chrome

When I do that the round gets replayed using chrome:sweat_smile: Do you have any errors in your browser console?

I’m getting the same behaviour as @KageNinja - can provide some more info when I’m back at my desk

I await your feedback :sweat_smile:

I think it is from the new entelect code release?

Ya I have some console errors, not sure if they are relevant:

On chrome:

TypeError: Cannot read property ‘startsWith’ of null
at t.n.mapOccupier (Square.js:24)
at t.value (Square.js:83)
at Oi (react-dom.production.min.js:3785)
at Ri (react-dom.production.min.js:3776)
at Mi (react-dom.production.min.js:3960)
at qa (react-dom.production.min.js:5514)
at $a (react-dom.production.min.js:5536)
at Ol (react-dom.production.min.js:5958)
at Pl (react-dom.production.min.js:5925)
at Tl (react-dom.production.min.js:5860)
da @ react-dom.production.min.js:4408


TypeError: Cannot read property ‘startsWith’ of null
at t.n.mapOccupier (Square.js:33)
at t.value (Square.js:83)
at Oi (react-dom.production.min.js:3785)
at Ri (react-dom.production.min.js:3776)
at Mi (react-dom.production.min.js:3960)
at qa (react-dom.production.min.js:5514)
at $a (react-dom.production.min.js:5536)
at Ol (react-dom.production.min.js:5958)
at Pl (react-dom.production.min.js:5925)
at Tl (react-dom.production.min.js:5860)
da @ react-dom.production.min.js:4408


Uncaught TypeError: Cannot read property ‘startsWith’ of null
at t.n.mapOccupier (Square.js:24)
at t.value (Square.js:83)
at Oi (react-dom.production.min.js:3785)
at Ri (react-dom.production.min.js:3776)
at Mi (react-dom.production.min.js:3960)
at qa (react-dom.production.min.js:5514)
at $a (react-dom.production.min.js:5536)
at Ol (react-dom.production.min.js:5958)
at Pl (react-dom.production.min.js:5925)
at Tl (react-dom.production.min.js:5860)

On firefox I’m getting something that looks more relevant:

Then the error is caused by the lack of the two CSV files that contain the moves. They should be in the root of the replay folder.

Im also getting the same console error as @japes on chrome.

Running the latest Game engine, using Chrome, both CSV files are in the replay root folder.

Edit: My earlier replays before the game engine update still run.

hmm :thinking: Will have a look then over the weekend.

Okay so it seems like there is an issue in the latest release where two columns in the csv file is populated with “null”.
I created a new topic here: Bug in output files of Release 2019.1.0 runner

3 Likes

This has been resolved. We have not released a new starter pack yet, but if this issue is affecting you, please use the game engine version on the develop branch of our repo.

1 Like

Good news, I made some changes, and the visualiser will work with any release version of the game engine. You will not just not have access to the move info on the left hand panel, or the visual indicators on the worms in the release where move info is unavailable.

Good luck everyone!

Thank you for the Visualiser! I have used it now for the first time and it works beautifully. A great help to look at the tournament match logs.

1 Like

You can now see if a worm uses a banana in v0.1.10 image
I will next try to indicate the target of the banana bomb.

3 Likes

Looks like the output from the current round crashes the visualiser - the whole interface just disappears!

Also, thanks for creating this - has been super useful to watch the match replays.

I’ve noticed this as well on some matches.

I noticed if I clicked slower a few times before dropping, it loads, I did click faster after it loaded so I could see the actions.

I will have a look tonight or over the weekend to see what is up.

3 Likes

If there is a “nothing” command, the CSV output for that line is corrupted (the inverted commas are strangely applied). I think the visualiser is falling over trying to parse it.

The visualiser is excellent, btw. Has been a wonderful aid.

1 Like

Thanks for that hint @PhoneticallyUnstable , it helped me to find and fix the issue.

I have deployed version 0.1.12 with a hack for the corrupt csv.

Could you please test?

Sorry for missing this, I didn’t explicitly dev a bot for this round, so I didnt check any replays.

Let me know if you find any other issues.

2 Likes