Bot not running properly when it is uploaded

when I run the game engine and my bot on my PC, I get the following

However, the game then runs on my PC.

When I attempt to upload the Bot, the load and build works fine, but I get the following message for each round

GameError - Player 1, worm 1, round 1: Unknown command: No Command

What am I doing wrong?

Hi @thinus

This is very strange. We will have a look and let you know if we find something.

Have you downloaded the “compiled” files and looked if they are indeed correct?

The build shows “success” and the build logs show an exit code 0. I do not see any other files.

Is it not maybe that your code in the cloud is timing out after taking more than 1 second to compute the command?


no. The code executes hundreds of rounds on my PC. Once uploaded it fails on every round until it dies…

I uploaded the python sample bot and it worked fine. So the problem must be on my side. Thanks for the assistance.

Thanks for the feedback.

We have looked at your upload and saw that you are importing some of the helper files provided in the starter bot, but you didn’t upload them in your submission.

Please try your upload with the addition of the following three files in you zip:

1 Like