Bot submission issue

Hi folks,

Is there an issue with the submission portal? My bot uploads and builds succesfully, but fails when running matches.

18:49:13,901 ERROR Exception during match execution Request failed: Request{method=POST, url=http://localhost:55556/instantiate_bot, tags={class [okhttp3.MultipartBody$Part@18d87d80]}}
	at ~[game-runner.jar:?]
	at ~[game-runner.jar:?]
	at<init>( ~[game-runner.jar:?]
	at ~[game-runner.jar:?]
	at ~[game-runner.jar:?]
	at [game-runner.jar:?]
	at [game-runner.jar:?]
18:49:13,904 INFO Notifying of match failure
18:49:14,713 INFO Creating zip: 3565b63c-9562-4075-a8e5-fd9e4271253b for directory: ./match-logs
1 Like

I’m also having issues, but in my case the submission got stuck on the match playing phase (I can’t download the match logs since the match won’t finish)


@kobus-v-schoor - shot in the dark - how big is your built/compiled artifact?

I had the same symptoms at one point (build artifact was like 750Mb - I suspect the runner didn’t have enough available RAM to actually load that…).

Hi @demaniak - thanks for the suggestion, unfortunately I don’t think that is the issue. The build artifact is only ~25MB big and the actual submission is even smaller. I made a very similar submission earlier for phase 3 and that didn’t have any issues running.

1 Like

I also see the issue with the submission being stuck as in progress. Also tried with version of my bot that previously succeeded and it still didn’t finish the match with the reference bot this time.

1 Like

@KyleMc, @floreggian_entelect, @pierre.roux any feedback on why the Player Portal only shows in progress for new submissions?


Hi @GawieJooste

I we haven’t pinned down the issue on the uploads yet, just wanted to give feedback that we are still looking into this

1 Like

Mine is also failing now.
It used to be 70 MB in size. It’s only 26 MB now so it’s weird.

Hi @rfnel and folks,
Sorry for the delay but we found the problem and it should be fixed now. Please let us know if this issue persists.


@RenierLR thanks, is it a problem that my previous submissions are still running (just want to make sure they won’t be used for my final submission)?

EDIT: just tested it and it works, thank you

Hi @RenierLR, I’m now getting this issue still. Is the submission of a README.MD file made mandatory?

21:18:17,575 ERROR Failed call: Request{method=POST, url=http://localhost:55555/instantiate_bot, tags={class [okhttp3.MultipartBody$Part@d29f28]}}

21:18:17,575 INFO Retrying request: Request{method=POST, url=http://localhost:55555/instantiate_bot, tags={class [okhttp3.MultipartBody$Part@d29f28]}}

21:18:47,814 ERROR Exception during match execution

java.lang.IllegalArgumentException: Failed to find bot meta data from location: tournament-tmp/extracted/player-3a9dfbb9-e889-41f5-b88b-95fda871eb87/

Hi @marvijo, this is an ongoing problem we have seen. As far as we know it isn’t necessary but sometimes that issue arises. Is it safe to assume that you don’t have a README.MD?

I added a file and the match executed

I haven’t seen this yet with my Python submission and I don’t have a README - is there a possibility that this issue only occurs with certain languages (presumably Java)?

I’m using Java and I haven’t had this issue. It would be nice to know to avoid last minute submission failures.

I have a readme and hit this issue last night. C++ bot. very similar submission worked just before it.
Also I now have a submission that has been “pending verification” for 24 hours… :grimacing:

Just successfully submitted the same bot that was failing previously. Looks like it’s an intermittent issue, so I guess just keep resubmitting until it passes.

I left all the default files from my first bot, seems like the readme needs to be in uppercase, seems like an odd error.