Connection refused on python

Hey, :wave: I’m new here… I entered this competition; using the python bot; I’ve followed all the setup steps… though when I try to run ‘python3 StartBot.py’; I get a connection refused error on … I tried allowing port 5000, by either adding a firewall rule, or just disable my firewall, on had on luck, so I came here seeking some solution(s), to this error, thats caused by StarterBot.py line 63… hub_connection.start()

unfortunately, this error prevents to get started, I’ve checked the net, and pypy for a solve to no avail … please look into this.

I’ve attempted to run the StarterBot.py on 2 Linux distributions; Ubuntu Mate for raspberry-pi 3 and on ElementaryOs 18.04… and both distros have the same issues mentioned on the above post. Which signalrcore module version must be installed to make to run? be default I’m given signalrcore that doesn’t specify the version number on requirements.txt file

Hi @sir.afrika, great to see you here! Good luck with the competition this year!

That “Connection refused” you are seeing - it means your bot cannot see the runner.

When you are running your bot, are you also already running the engine and runne somewhere?

You should have a terminal open, repeatedly printing “Waiting for all bots to connect”. Are you seeing that?

I’m not seeing the “Waiting for all bots to connect” message on the terminal, I initially see the

http://localhost:5000/runnerhub

then it crashes with the message -> “connection refused error 111” on line 63

I’ve committed, can please look into it on github

This maybe the issue…

check the known issues section

So we can’t actually see into your private repository, so unfortunately I won’t be able to take a look for you.

However, can you please try navigating to “http://localhost:5000/runnerhub” before starting your bot, in your browser?

You should see one line of text saying “Connection ID required”. Do you see this?

Hello, I am also having the same problem but with Javascript (when running ‘node javascript_StarterBot.js’ in the terminal).

I get the error message “Error: Failed to complete negotiation with the server: FetchError: request to http://localhost:5000/runnerhub/negotiate?negotiateVersion=1 failed, reason: connect ECONNREFUSED 127.0.0.1:5000

Disconnected”

When I navigate to http://localhost:5000/runnerhub on the address bar, I get the message “localhost refused to connect.”

What am I doing wrong?

Hi @itumel,

Could you please try https instead of http as I’ve seen this negotiation issue come up with the different protocols, also how are you starting the runner?

Please let us know if there are any further questions on this.

Hi @ibvs,

My apologies. It seems I am struggling to find the instructions on how to run the project properly.

I am not finding the runner.

I tried ‘node client.js’ under my /starter-pack/runner-publish/wwwroot/js, nothing happened. So I am assuming this is not the runner.

So how do I go about running the runner?

Also https doesn’t seem to make a difference over http.

No worries @itumel :slight_smile: ,

Please ensure you have the latest starter pack and follow the readme docs (You can start with the main readme file in the base folder and work your way through each component), please let us know if something needs to be clarified.

Thank you for your help.

I noticed that there are two zip files in the 2021-Galaxio github repo.

I downloaded starter-pack.zip and had trouble getting started.

I went back to download Source Code (zip).

I should have started with the README.md’s there instead. They explained everything (like how to get started, etc.) and better at that.

So now I am just waiting to install and run .NET Core SignalR Hub.

Will update as I go along.

It’s a please @itumel,

Please feel free to reach out if anything is unclear.