Errors with CI/CD


Probably doing something silly on my side, I see others have successfully submitted c# bots…

but when I try, I get errors in the CI/CD jobs in my repo, and nothing pops up under my submissions on the site.

Has anyone run into something similar?

Figured this out, for anyone else who runs into this…

The c# starter bot doesn’t ship with a Dockerfile for some reason (all the other starter bots do…?)

So I copied in the one from last year, and that sorted it out.

Update: that sorted out the building/submission, but matches fail with the following in my bot log:

{"date":"2024-04-21T12:53:54.156466Z","log":"It was not possible to find any compatible framework version"}
{"date":"2024-04-21T12:53:54.156675Z","log":"The framework 'Microsoft.NETCore.App', version '8.0.0' was not found."}
{"date":"2024-04-21T12:53:54.156742Z","log":"  - The following frameworks were found:"}
{"date":"2024-04-21T12:53:54.156805Z","log":"      5.0.5 at [/usr/share/dotnet/shared/Microsoft.NETCore.App]"}
{"date":"2024-04-21T12:53:54.156930Z","log":"You can resolve the problem by installing the specified framework and/or SDK."}
{"date":"2024-04-21T12:53:54.156997Z","log":"The specified framework can be found at:"}
{"date":"2024-04-21T12:53:54.157047Z","log":"  -"}

So I think the Dockerfile I’m using is out of date, and we need a new one please :pray:

@japes I ran into the same issue when building a dockerfile for the engine, you can probably make use of for the build stage and for the run stage

1 Like

once again you come to the rescue sir!

Thanks. changed the base image to and it worked.
1000 glorious ticks of aimless meandering around the garden.

status is still failed and “match logs” gives nothing though, but i believe that’s expected atm?

1 Like