Game engine completely dying


Im still running the second Tournament engine, I will shift over to the third one very soon as Im basically done with my building implementation.

While playing I ran into the following problem with my bot:
[DEBUG] [error]: 0097617a-6941-4121-add4-f28085cff1ed does not exist
[DEBUG] [Debug]: Target Node 0097617a-6941-4121-add4-f28085cff1ed has been is no longer avaialble

From the game engine this triggers if Node is Null

if (node is null)
Logger.LogDebug(“Debug”, $"Target Node {playAction.TargetNodeId} has been is no longer avaialble ");

Was this something that someone else observed and was this something that was maybe fixed in the third harness?
I have no way of replicating the error in the new harness. What I am doing now is debugging what action I tried to make that caused it… Maybe I can try and force the seed.

Regardless of the method.
Something causes a node that use to exist to “disappear”

I am analyzing this myself. The main issue I have with this specific issue is that it completely crashes the engine.

Instead of allowing the game to continue.
Assuming my own bot caused the error to begin with.
I do not feel that this should completely stop processing commands indefinitely.

The case is good because I can trace the cause and see if its a Game engine issue or just bad logic on my part.

But in either case i do not feel that it should stop all future commands from being processed either.
**If one player’s bot does submit some invalid node. And it does trigger that error.

I will assess if I can find the exact trigger.

I suspect im trying to build on a node that I am unable to build on for some reason.
I will also try and replicate this in the third engine.
Im just posting here incase anyone beside me knows something


So I found a small logical issue in my own bot:

Essentially I assigned x and y values from a preset array, Then I sorted that array. And set my node ID afterwards.

This resulted in a node ID mis match between my X and Y values.
So I would technically be able to try and build on the same node twice.

I will confirm this after a test, by saving my first building Id and retrying that action once I have enough resources.
I will then also test that case in the third harness.

My concern with the error completely stopping command processing is i can play up a lead,
And then crash the engine.

Possibly winning early on as a result.

I will write a test case for this issue and see if the third harness also gives it.
I know its a clear logical issue on my part. But as I mentioned.

It should not stop the game engine from future processing.

Hey @WillieTheron, I strongly suspect it’s this issue that I reported a while back:

You are correct,

That is definately the issue.

I would not even had noticed it if I didnt make a mistake in my own logic.

Your fixing a lot of the issues im running into :stuck_out_tongue: