GitHub storage limits hit :(

GitHub decided I hit the storage limit :frowning:

I’ve manually deleted all action artifacts, but it still seems unhappy.

Anybody got a clever and/or quick fix?

Side note: I’ ve spent some time in the workflow file already… I’m suspecting the problematic action might not be necessary - since the whole app is built inside the docker container. It seems unnecessary to have a step that is running mvn before we get into the docker container.?

Maybe it’s storing your image artifacts. A docker prune might work?

That would be weird, but it is definitely worth a try.

Thanks @Izak

Unfortunately seems docker was not the issue.
But I’ve kludged the workflow file to avoid using artifact storage - basically just produce and push the docker image, and rebuild the project when needed to accommodate the uploads of source and built artifacts to S3.

Hope that will suffice !

1 Like

Ill probably setup a self hosted runner to overcome this issue, I do see a lot of people suddenly received this issue this month

1 Like

Could it be that Github has imposed new limits on the public runners?

1 Like

Just to put some more info out there: according to the email from Github, I was using “736MB of 512.0MB included”.

I have since deleted all artifacts stored on action runs, but , no luck on that. Even started deleting entire workflow runs.
I really did not have that much in there, as far as I can see.

So, seeing as how I allegedly managed got go 224Mb over the limit - that kind of argues for new limits introduced recently.
One more data point: again, as far as I can see, it was something like 20 - 40Mb storage per successful action run.
So they had plenty of time to start complaining over the last 2 months - and yet, they did not.

@demaniak You flippin’ smart oke. Removing the build sections from the workflow YAML (and doing the build in the docker file from source) seems to sort this issue out. Now if only the matching worked so we could confirm…

1 Like

I have my moments.
Not only if some of that alleged cleverness could transfer to this damn bot of mine…

What do you mean “the matching worked”?

@Izak The stuck in queue issue is still persisting:

Have you submitted since yesterday because we found an issue with our API?

All of those are after 3pm yesterday

Oi! Okay, anything in the chrome console?

No errors, network tab just has valid JSON in it showing the entries.
Latest submisison details if you’d like to dig more:

Ah! I believe it is fixed now. Cloud infrastructure is so fragile :sweat:


Yeah… I think people who really work with this stuff are definitely on the other side of the hype hill by now…

I think Github is just slow to update the spending limits, after I deleted all my action history it only reset after 72 hours.

1 Like

72 hours!?


But, I guess, since they clearly are trying to guide you into becoming a paying user, I guess that crap turn-a-round time makes sense.

Yes seems so, i just setup a local runner so the limit does not apply anymore