Python bot fails on new update

Hey guys.

Thank you for hosting an awesome AI coding challenge yet again. This morning I downloaded the new starter pack. I tried downloading it through the website, but the link seems to be broken. I thus downloaded the new version from this forum. The java bots seem to work on the new engine, but for some reason when I run my python bot or the starter python bot I get the “py” program not found. I tested it with python3 and python2. Can anyone confirm this or tell me how to fix this problem?

For now I am working with the first starter pack.

Interesting: it is running “py -2” or “py -3” - I write Python all the time and I’ve never heard of this. Turns out it works for me on Windows, but not on Linux, so guessing you’re on Linux?

This should probably be fixed in the bot runner, but for now, here’s a quick bash script that fixes the problem. Save it as /usr/bin/py (and chmod a+x /usr/bin/py of course):


if [ $1 -eq -3 ]
	python3 ${@:2}
	python ${@:2}
1 Like

Hi guys,

This was an oversight on our part, we’ll look into fixing this ASAP, thanks for the workaround there @Malman.
We’ll let you know as soon as this is fixed!

I am using linux yes.

Thank you, Malman and GeelKanarie.

Late but maybe it’ll be useful to other users.

I had a similar problem and unintentionally fixed it by installing the 64-bit version of python (because of TensorFlow). For some reason I had the 32-bit version before.

I have 64-bit version:

Python 3.6.1 |Anaconda 4.4.0 (64-bit)| (default, May 11 2017, 13:25:24) [MSC v.1900 64 bit (AMD64)] on win32
Type “help”, “copyright”, “credits” or “license” for more information.

but still:

Bot execution failed: Cannot run program “py” (in directory “d:\projects\entelect\starter-pack\starter-bots\python3”): CreateProcess error=2

This also tripped me up a bit. Assuming you’re on Windows, there’s a Python launcher you need that drops py.exe into your Windows folder. This explains it:
Download is here: