Seems like the Game Engine is only available for Windows?

If I use the .NET Core Runtime for Linux or OSX, will the game engine be able to run?

Hi Shiraaz,

We did not use .Net core to compile/write the game engine so I am a little doubtful that it will work. You are more than welcome to give a shot and let us know?

The game engine runs under Mono - just put “mono” before the command you’d use to run the game on Windows (“mono GameEngine.exe …”).

You may need other workarounds to get things going: so far I have needed to symlink /usr/bin/python3 to /usr/bin/python.exe to get Python bots running!

I was very doubtful… but tried mono and it worked without any trouble. I just copied the .bat into a .sh and made some small changes to it. It ran without any trouble in the real OS * wink-wink * :wink:

May as well try it out just to see what happens :slight_smile:

Will try the mono suggestion in the other replies. Thanks guys

@ShiraazM I was able to build the GameEngine using the latest mono. I had a makefile to do this but it looks like it’s been removed. I will find you the exact incantations so you may be able to reproduce.

Note, you do need to compile the latest Mono from source, since Ubuntu’s version was still used by Noah to build the Ark’s control system. :stuck_out_tongue:

1 Like

Here you go

It seems after @amanica removed my Makefile from my doc it was also removed from the rest of the repo later :scream_cat: remember to use “xbuild” instead of “msbuild”. Also installing Nuget is required but there are cross platform support for that also.

I hope it helps.

Yeah I noticed, it is pretty weird. I tried to add it again now: