Strange timeouts


I’ve noticed timeouts in a few strange places for no clear reason.

I’ve also had it happen when playing the reference bots against each other, does anyone else see this happening?

I have not seen that happening. Have you confirmed the file exists? maybe there is a lock on the file.

With the javascript bot me and fellow office mates have had unexplained timeouts. Thinking it might be AV…

Ive had this issue too actually, and when it happens and you check the match logs, BotOutput.txt is completely empty (Even if there is a forced output when the bot gets launched). It gives the impression that the bot did not even execute. Also explains why the command.txt file doesnt exist.

1 Like

Yeah I also tried printing output at the start, but nothing. I’ve been unable to replicate the error though. I’ve also tried doing stuff at the end to make the bot timeout, but even then if the command.txt file exists the move is processed correctly.

maybe it’s just a windows thing ?

I keep getting the strange error on my C# bot as well but strangely only with round 1 and 2 and plays fine there after. I tried debugging with the game state but it works 100% fine. I assume it is due to the run time environment starting up which sometimes takes more than 2 seconds?

Starting game

Starting round 0

BotRunner Started.
Bot execution failed: Process exited with an error: 1 (Exit value: 1)
BotRunner Started.
File C:\Users\vanni\Desktop\starter-pack\mybot/command.txt not found
Error List: []

Player A Health=100, Energy=5, Score=6
Player B Health=100, Energy=25, Score=5
[0e0][1 0][2 0][3 0][3 0][2 0][1 0][0 0]
[0 1][1 1][2 1][3 1][3 1][2 1][1 1][0 1]
[0 2][1 2][2 2][3 2][3 2][2 2][1 2][0 2]
[0 3][1 3][2 3][3 3][3 3][2 3][1 3][0 3]

Hmmm;;;; that is strange.

@Kortgat, do you get this error consistently? If so can you maybe set the max-runtime-ms a bit higher and see if that fixes it.

Just as an FYI if this is the issue. During the tournament and when running your bot matches on upload we will be running a “calibration” bot that adds the language’s start time to the 2 seconds, so that you don’t have to worry about the startup being an issue with your bot’s actual command time.

Increasing the timeout to 10000 worked like a charm, So looks like a run time issue thanks.

My submit still has timeouts for some reason. My bot is only using 1.8 seconds which is way below the required. Is the calibration being applied to the test games played on the server when we submit?

1 Like

Same thing happens to me @GeelKanarie please assist, my python bot reports 1.5 seconds, but the bot output says “Bot execution failed: Bot process timed out after 2000ms of inactivity”,

I deliberately wrote something on the log when the bot starts but there’s nothing in the BotOutput.txt file. There are no libraries taking up loading time and increasing the timeout solves the issue. But we need assurance that our bots execute in the allocated time.

How does the calibration work so we can simulate a similar environment?

Hi @marvijo,

The calibration works by running an empty bot, essentially an empty main function, before running yours to calculate the base language startup time. This time then gets added to the bot’s available time to essentially give it 2 seconds of solid run time minus language startup.