Possible Submission Issue

Hi folks,

I’ve submitted a few versions of my bot via the automated submission flow. If I look at the status on the player portal, the submission and build phases were successful, but all the matches failed. The bot logs and game runner logs are both empty.

Can anyone give me some insight into why this is happening? Is my bot broken somehow?


1 Like

Can you please try the legacy upload flow while we debug the issue.

Here is the error: {“date”:“2021-04-02T19:33:28.912231Z”,“log”:“Error: Unable to access jarfile JavaBot.jar”}

You changed the finalName in your pom.xml from JavaBot to BottyMcBotface. Thus changing the jar’s name that gets created by the maven build process. Which causes the error above

Thanks for the update. I tried to run it through the manual submission process last night, but I was getting timeouts trying to access the player portal.

Can I still compete in this tournament? I know the engine works differently this year, but my final JAR file name has been “BottyMcBotface.jar” for every challenge over the past couple of years. I don’t recall anything in the docs stating that the final JAR requires a specific name and that that won’t work anymore. It works fine if run the game engine locally, but I don’t use the Docker file - I just run it via the run.sh script.

So there are no limitations to what you can name your bot.jar if you can make it run on our infrastructure. i.e working with the Dockerfile.

And we don’t believe this needs to be outlined in the docs as it was mentioned that “playing around” with default configs will typically end up with erroneous responses.

The team feels there was ample time to resolve this issue before the deadline, so unfortunately your bot will not make it into the first tournament. However there we will be rolling out friendly tournaments soon and so you will have a chance to compete against other players ahead of tournament 2.

Thank you for still being a valued member of the Entelect Challenge.

Hi @floreggian_entelect, I also got errors running a .NET Core 3.1 bot on the server, I got the following from uploading a .NET Core bot:

{“date”:“2021-04-29T15:43:19.363840Z”,“log”:" It was not possible to find any installed .NET Core SDKs"}

@marvijo Please send an email to challenge@entelect.co.za. Please contain the email address which you have logged into the Entelect Challenge Portal.

1 Like

Fair enough.

I’ve tried to rectify the issue and I’ve submitted a new version of my bot. However, I can no longer see my submissions on the player portal. It seems to be coming back with an HTTP 500 response.

Riaan, since midnight on 1 May when I visit the submission page I only get the spinning hamster wheel. They probably closed it while the competition is running.

1 Like

Good Evening @kuifie and @rfnel.

We are investigating the player submission issue that you are seeing, and will be fixing the issue promptly.

Thank you for making us aware of the issue.

Good Evening @kuifie and @rfnel,

You should be able to view your submissions now again. Should there be any further issues, just reply here and I will pick it up again.

Thank you for your patience.

1 Like

@marno.vanniekerk: FYI --> I still get the spinning hamsterwheel on the submission page. Waited a few minutes.

Good morning @kuifie, Please check for me if you can now retrieve your submissions?

Still not working for me.

Good evening @kuifie.

The submissions issue should really be sorted now. We made some Database optimizations for the massive data that was gathered during the tournament.

Thank you for your patience.

Good evening @marvijo. We did not forget about you. I did investigation into your bot and saw that your namespace is different from what the Dockerfile expects.

Your namespace is MarvijoBot.Galaxio, which will produce a MarvijoBot.Galaxio.dll when it’s built during the build process.
In your Dockerfile, the entrypoint is as follows: ENTRYPOINT ["dotnet", "ReferenceBot.dll"].
That command will look for a file called ReferenceBot.dll to run your bot. Since yours is called MarvijoBot.Galaxio.dll, it’s not finding the correct file.

To fix your submission, you will just need to change the entrypoint command from ENTRYPOINT ["dotnet", "ReferenceBot.dll"] to ENTRYPOINT ["dotnet", "MarvijoBot.Galaxio.dll"].
That will enable Docker to run the correct file to run your bot on our system.

Happy coding! And thank you for participating this year as well! :slight_smile:

1 Like


Still not working for me. Console output shows Error 500. I have tried on other computers and get the same, so it is not a caching problem on my side.

Hi @kuifie, It should really be fixed now. Please let me know if you are having any further troubles.

1 Like

Hi folks,

Something weird is happening on my submission again. Now that the issue with the game engine and Java bots has been fixed, I can run my bot locally.

As soon as I upload it to the portal and it runs a test match on there, it registers with the runner and then crashes. I’ve wrapped try/catch statements around my code to try and get an idea of what’s going wrong, but I can’t see anything more in the logs than the below.

{"date":"2021-06-02T19:16:51.559816Z","log":"[OkHttp] INFO com.microsoft.signalr.WebSocketTransport - WebSocket transport connected to: ws://"}
{"date":"2021-06-02T19:16:51.619807Z","log":"[OkHttp] INFO com.microsoft.signalr.HubConnection - HubConnection started."}
{"date":"2021-06-02T19:16:52.626989Z","log":"Registering with the runner..."}
{"date":"2021-06-02T19:16:52.698220Z","log":"Registered with the runner 5e588483-5a04-4fb6-a11f-70f0f6bb4fab"}
{"date":"2021-06-02T19:22:55.998515Z","log":"[OkHttp] ERROR com.microsoft.signalr.OkHttpWebSocketWrapper - WebSocket closed from an error: null."}
{"date":"2021-06-02T19:22:55.998647Z","log":"[OkHttp] INFO com.microsoft.signalr.WebSocketTransport - WebSocket connection stopping with code null and reason 'null'."}
{"date":"2021-06-02T19:22:55.998718Z","log":"[OkHttp] INFO com.microsoft.signalr.HubConnection - HubConnection stopped."}

Can you please have a look?